DTP


 
Lively discussions on the graphic arts and publishing — in print or on the web


Go Back   Desktop Publishing Forum > General Discussions > Web Site Building & Maintenance

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-02-2012, 06:11 PM   #1
annc
Sysop
 
annc's Avatar
 
Join Date: Oct 2004
Location: Subtropical Queensland, Australia, between the mountains and the Coral Sea
Posts: 4,436
Default Password protecting a directory

I'm setting up a test vB system and need to password-protect the directory it's in to comply with vB licence requirements. Now I've done this before, but it was a long time ago and also before my hosting company, United Hosting, changed to cPanel.

Here's what I have done:

First, I went to Dynamic Drive and used their .htaccess password generator. So I now have a .htpasswd file that looks like this:
Code:
people:Qauo8FTnoC4Ds
It's sitting in one level above public_html as suggested. In Fetch, that level appears to have just a slash in front of it when looking at server paths.

I then copied the .htaccess code from Dynamic Drive, altered the server path as I thought it should be, and placed it in the directory containing the vBulletin test system files. This is what the .htaccess file looks like:
Code:
AuthName "Restricted Area" 
AuthType Basic 
AuthUserFile /mysite.com/.htpasswd 
AuthGroupFile /dev/null 
require valid-user
Obviously I have the real site name there.

When I try to access the test site, I get the authentication dialogue box and enter the username and password. However, I then get a 500 with the following message:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@mysite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
I have put a blank 401.shtml in public_html but it doesn't seem to be finding that, either.

Obviously I'm a real novice when it comes to .htaccess, so need some help here.

TIA.

   
__________________
annc is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Useful-looking food directory site ktinkel The Corner Pub 1 06-28-2011 10:30 PM
Protecting Word documents Robin Springall Print Design 30 12-08-2010 07:06 AM
Protecting privacy on Facebook ktinkel Business Matters 11 05-09-2010 01:13 PM
protecting online forms john_b Web Site Building & Maintenance 6 03-10-2007 05:45 AM
open source directory Bo Aakerstrom Web Design 1 07-20-2006 03:27 PM


All times are GMT -8. The time now is 04:29 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Contents copyright 2004–2014 Desktop Publishing Forum and its members.