DTP


 
Lively discussions on the graphic arts and publishing — in print or on the web


Go Back   Desktop Publishing Forum > General Discussions > How to Use the Forum

Reply
 
Thread Tools Display Modes
Old 08-17-2006, 07:34 AM   #1
gary
Member
 
Join Date: Dec 2004
Location: In the heart of Lake Minnetonka
Posts: 337
Default Avatar is now a link?

I just noticed that instead of displaying an Avatar image the forum now displays a link (titled, for example, "Gary's Avatar) to the image. Was this some sort of recent security change?
gary is offline   Reply With Quote
Old 08-17-2006, 09:20 AM   #2
iamback
Member
 
iamback's Avatar
 
Join Date: Oct 2005
Location: Amsterdam, NL
Posts: 4,894
Default

Quote:
Originally Posted by gary View Post
I just noticed that instead of displaying an Avatar image the forum now displays a link (titled, for example, "Gary's Avatar) to the image. Was this some sort of recent security change?
Actually it's a brolken image and what you see is the alt text. The src attribute of the image tag is an empty string; and the image itself is the content of an a tag, which makes the alt text appear as a link.

I notice a ghost of other changes (mostly a lot of links that now have a rel="nofollow" attribute): it looks as though an upgrade of the forum software was done but somehow something went wrong with the avatars (I checked that mine still exists in my profile).

   
__________________
Marjolein Katsma
Look through my eyes on Cultural Surfaces (soon!), My ArtFlakes shop and Flickr.
Occasionally I am also connecting online dots... and sometimes you can follow me on Marjolein's Travel Blog
iamback is offline   Reply With Quote
Old 08-17-2006, 10:30 AM   #3
ktinkel
Founding Sysop
 
ktinkel's Avatar
 
Join Date: Oct 2004
Location: In Connecticut, on the Housatonic River near its mouth at Long Island Sound.
Posts: 11,189
Default

Quote:
Originally Posted by gary View Post
I just noticed that instead of displaying an Avatar image the forum now displays a link (titled, for example, "Gary's Avatar) to the image. Was this some sort of recent security change?
Sort of. Big vB upgrade, and we are still trying to settle the aftershocks.

Somehow the avatars — but not the sigs — got lost, along with some other elements. Patience, s’il vous plait!

::

   
__________________
[SIZE=2][COLOR=LemonChiffon]::[/COLOR][/SIZE]
[SIGPIC][/SIGPIC]
ktinkel is offline   Reply With Quote
Old 08-17-2006, 10:52 AM   #4
iamback
Member
 
iamback's Avatar
 
Join Date: Oct 2005
Location: Amsterdam, NL
Posts: 4,894
Default

Quote:
Originally Posted by ktinkel View Post
Sort of. Big vB upgrade, and we are still trying to settle the aftershocks.

Somehow the avatars — but not the sigs — got lost, along with some other elements. Patience, s’il vous plait!
Nope - like I said my avatar is still there in my profile - what got "lost" was the path to them in the image tag generated. In my profile it seems to be a filesystem path, so apparently it's still sitting on the server - maybe the database has "lost" the file location, or just the name of the directory where they're stored?

Another thing I noticed: clicking on an attachment now opens it in a new window instead of the same one - I don't like that at all, since it takes away my control of how or where to open it.

And I seem to remember there was a "submit" below a post preview; if so, that has disappeared. (Probably a good thing - you could end up with a confusing three different submit buttons on a page with no indication whether they would do the same thing or something different.)

The rel="nofollow" is of course an improvement.

   
__________________
Marjolein Katsma
Look through my eyes on Cultural Surfaces (soon!), My ArtFlakes shop and Flickr.
Occasionally I am also connecting online dots... and sometimes you can follow me on Marjolein's Travel Blog
iamback is offline   Reply With Quote
Old 08-17-2006, 12:29 PM   #5
ktinkel
Founding Sysop
 
ktinkel's Avatar
 
Join Date: Oct 2004
Location: In Connecticut, on the Housatonic River near its mouth at Long Island Sound.
Posts: 11,189
Default

Quote:
Originally Posted by iamback View Post
Nope - like I said my avatar is still there in my profile - what got "lost" was the path to them in the image tag generated. In my profile it seems to be a filesystem path, so apparently it's still sitting on the server - maybe the database has "lost" the file location, or just the name of the directory where they're stored?
The avatars had been stored in the database. The upgrade moved them to the server, where I can see them clearly, along with the path. What I do not understand is how to fix the PHP (of course!)

Maybe you can help. It looks like this:
<img src="$avatarurl" alt="<phrase 1="$post[username]">
$vbphrase[xs_avatar]</phrase>" border="0" />
I see that variable, but do not know where it is defined. Searching on it in templates and stylesheet does not help. So. I tried replacing the "$avatarurl" with the path name "customavatars" but the path is still blank.

Quote:
Originally Posted by iamback
clicking on an attachment now opens it in a new window instead of the same one
Hmmm. I thought it always opened a new window. But I made a note — no reason not to change it, regardless.

::

   
__________________
[SIZE=2][COLOR=LemonChiffon]::[/COLOR][/SIZE]
[SIGPIC][/SIGPIC]
ktinkel is offline   Reply With Quote
Old 08-17-2006, 01:04 PM   #6
iamback
Member
 
iamback's Avatar
 
Join Date: Oct 2005
Location: Amsterdam, NL
Posts: 4,894
Default

Quote:
Originally Posted by ktinkel View Post
The avatars had been stored in the database. The upgrade moved them to the server, where I can see them clearly, along with the path. What I do not understand is how to fix the PHP (of course!)

Maybe you can help. It looks like this:
PHP Code:
<img src="$avatarurlalt="<phrase 1="$post[username]">
$vbphrase[xs_avatar]</phrase>" border="0" /> 
I see that variable, but do not know where it is defined. Searching on it in templates and stylesheet does not help. So. I tried replacing the "$avatarurl" with the path name "customavatars" but the path is still blank.
It might gets its value indirectly from a database query, with a database column being named 'avatarurl'. Can you find where in the database the path to the avatar image is being stored? And did you search all code files for the string 'avatarurl' (not necessarily with a $ prepended)? Even try just 'avatar' (without the quotes). It could be in an included file somewhere.

Any help on the vBulletin support forum (I assume there is one)? Surely others have run into similar upgrade problems.

   
__________________
Marjolein Katsma
Look through my eyes on Cultural Surfaces (soon!), My ArtFlakes shop and Flickr.
Occasionally I am also connecting online dots... and sometimes you can follow me on Marjolein's Travel Blog
iamback is offline   Reply With Quote
Old 08-17-2006, 03:43 PM   #7
don Arnoldy
Curmudgeon
 
don Arnoldy's Avatar
 
Join Date: Oct 2004
Posts: 496
Default

Quote:
Originally Posted by ktinkel View Post
I see that variable, but do not know where it is defined. Searching on it in templates and stylesheet does not help.
There is a field in the Admin control panel where you can set the file path--i don't remember exactly which panel its in (and don't have time right now to go search).

--don

   
__________________
--don
don Arnoldy is offline   Reply With Quote
Old 08-18-2006, 06:28 AM   #8
ktinkel
Founding Sysop
 
ktinkel's Avatar
 
Join Date: Oct 2004
Location: In Connecticut, on the Housatonic River near its mouth at Long Island Sound.
Posts: 11,189
Default

Quote:
Originally Posted by don Arnoldy View Post
There is a field in the Admin control panel where you can set the file path …
If you find out where, let me know. In the Images Control section you can set the path for every sort of image except avatars (unless they are included in one of the other groups, but if that is so, I cannot figure it out). And the template uses a $variable.

   
__________________
[SIZE=2][COLOR=LemonChiffon]::[/COLOR][/SIZE]
[SIGPIC][/SIGPIC]
ktinkel is offline   Reply With Quote
Old 08-18-2006, 01:44 PM   #9
iamback
Member
 
iamback's Avatar
 
Join Date: Oct 2005
Location: Amsterdam, NL
Posts: 4,894
Default

Quote:
Originally Posted by ktinkel View Post
If you find out where, let me know. In the Images Control section you can set the path for every sort of image except avatars (unless they are included in one of the other groups, but if that is so, I cannot figure it out). And the template uses a $variable.
Kathleen, any progress on searching the code for 'avatar' or 'avatarurl'? I also note that just before in the generated code there is a (HTML) comment with the text "path to user avatars in message windows": you might try searching for that exact phrase as well.

vBulletin support or forum?

Anything I could look at?

   
__________________
Marjolein Katsma
Look through my eyes on Cultural Surfaces (soon!), My ArtFlakes shop and Flickr.
Occasionally I am also connecting online dots... and sometimes you can follow me on Marjolein's Travel Blog
iamback is offline   Reply With Quote
Old 08-18-2006, 02:08 PM   #10
ktinkel
Founding Sysop
 
ktinkel's Avatar
 
Join Date: Oct 2004
Location: In Connecticut, on the Housatonic River near its mouth at Long Island Sound.
Posts: 11,189
Default

Quote:
Originally Posted by iamback View Post
Kathleen, any progress on searching the code for 'avatar' or 'avatarurl'? I also note that just before in the generated code there is a (HTML) comment with the text "path to user avatars in message windows": you might try searching for that exact phrase as well.

vBulletin support or forum?

Anything I could look at?
No (but thank you!) After spending time in the vB forums and posting there, I discover that we need to update completely to 3.6.0 and then redo our mods and addons in a separate step. Discouraging, but probably cleaner and more stable than trying, like this, to patch the old code with the new.

I made a reverted style today, as a test, and everything (including the avatars) work when we adopt the default 3.6.0. Except our goodies, of course. If we moved over our old header, then it would mostly be an issue of tweaking templates and CSS. And adding back our Get Posts/New Posts dropdown.

Right now I am weary of poking at this inert carcass and think it is past time for supper.

   
__________________
[SIZE=2][COLOR=LemonChiffon]::[/COLOR][/SIZE]
[SIGPIC][/SIGPIC]
ktinkel is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vote on Ian's avatar! ilox The Corner Pub 37 07-27-2006 05:41 PM


All times are GMT -8. The time now is 05:23 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Contents copyright 2004–2018 Desktop Publishing Forum and its members.