DTP


 
Lively discussions on the graphic arts and publishing — in print or on the web


Go Back   Desktop Publishing Forum > General Discussions > Fonts & Typography

Reply
 
Thread Tools Display Modes
Old 07-14-2005, 07:22 PM   #1
marlene
Staff
 
marlene's Avatar
 
Join Date: Oct 2004
Posts: 1,419
Default We are NOT family -- font weirdness in InDesign

I'm learning (or trying to) to use InDesign 4.

I've got a font problem that might be of my own doing, but I suspect it's an InDesign thang, and I can't figure out how to fix it.

My client complained about the kerning in Gill Sans (and to think I always said clients never notice things like that), so I adjusted it in TypeTool and resaved the family of four (I'm on PC) with new font names (I added MX to each filename to distinguish these versions of Gill Sans from off-the-shelf versions). I was VERY careful about naming the fonts, and was consistent (I double-checked) and had no spaces in any of the names.

But for some reason, Gill Sans shows up in ID as:

Gill Sans MX (the regular weight only)
Gill SansMX (italic, bold, and bold italic)

I cannot figure out where ID is seeing these two different font family names, especially since I didn't use spaces when renaming the fonts in TypeTool.

The renamed Gill shows up correctly in Quark and Word, and works correctly when the attributes are selected, which is why I think the problem is something to do with how ID handles fonts.

Anyone got any clues?

mxh
marlene is offline   Reply With Quote
Old 07-14-2005, 10:29 PM   #2
Shane Stanley
Staff
 
Join Date: Oct 2004
Location: Melbourne, Australia
Posts: 526
Default

ID is pretty fussy about fonts. Does your standard font have a style name at all? If not, try giving it a style name like Medium or Regular. As it stands, ID might be reading the "MX" as a style name.

Shane
Shane Stanley is offline   Reply With Quote
Old 07-14-2005, 11:25 PM   #3
marlene
Staff
 
marlene's Avatar
 
Join Date: Oct 2004
Posts: 1,419
Default

I am so exasperated. After monkeying with this for a couple of hours, I finally gave up and restored the original font names. I opened my ORIGINAL Gill Sans family in TypeTool and carefully made a list of all the exact names, including family name, font name, style name, menu name, etc. Then I opened my kerned versions and gave them the exact same names. Uninstalled the previous versions (MX) and installed the non-MX named versions.

I figured the problem is probably that InDesign expects all related typefaces to have ONE family name, and it has to match for all the various incarnations of that typeface -- regular, bold, bold italic, compressed, light, heavy, extra bold italic, ultra light, etc.

Anyway, for some reason, my MX-named fonts are STILL showing up in ID's font list! They aren't installed any more -- they aren't even on the same hard drive -- I moved them to a different drive where ID has no business looking. I double checked to make sure no copies of the MX fonts were in any font folders that ID has access too.

I turned off the printer and the computer completely. Upon startup, those friggin' MX fonts are STILL showing up in ID's font list. And none of the fonts with the restored names are showing up.

I can't understand why the ID font list still shows fonts that are no longer there.

UPDATE: I finally got rid of the problem. I literally deleted the old MX font files from my system, although they were on a completely separate hard drive. I uninstalled the new versions through my font manager. Threw salt over my left shoulder and reinstalled new versions.

Launched ID, and saw that dadgummed phantom font at the bottom of the font list (in parens), but after I opened a document, and applied another font, the phantom disappeared.

This computer is clean!

mxh

Last edited by marlene; 07-15-2005 at 12:21 AM.
marlene is offline   Reply With Quote
Old 07-15-2005, 10:25 AM   #4
Michael Rowley
Member
 
Join Date: Jan 2005
Location: Ipswich (the one in England)
Posts: 5,105
Default

Marlene:

Threw salt over my left shoulder

That probably did the trick, but Windows Registry might have been to blame, since there's a lot of information about fonts there.

   
__________________
Michael
Michael Rowley is offline   Reply With Quote
Old 07-15-2005, 05:59 PM   #5
marlene
Staff
 
marlene's Avatar
 
Join Date: Oct 2004
Posts: 1,419
Default

Quote:
Windows Registry might have been to blame, since there's a lot of information about fonts there.
Could be -- WTF do I know! <g> -- but none of my other applications were similarly afflicted. Only ID was seeing ghosts of typefaces past.

mxh
marlene is offline   Reply With Quote
Old 07-18-2005, 02:02 PM   #6
terrie
Staff
 
Join Date: Oct 2004
Posts: 8,931
Default

I wonder if they might have been in ID's pref's file and/or still in Window's font list?

Also, it will show the font in parens if a document has a reference to it which will disappear when you apply a different font...

Terrie
terrie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Font probs: Mac Suitcase InDesign ktinkel Fonts & Typography 0 12-26-2006 12:43 PM
font-family: "Comic Sans MS" dthomsen8 Web Site Building & Maintenance 7 11-04-2006 08:07 AM
InDesign-PDF Font Frustration Cyranetta Fonts & Typography 32 10-07-2006 03:03 PM
Free sans family: Kaffeesatz ktinkel Fonts & Typography 8 03-29-2006 01:58 PM
'Incomplete' TrueType font in InDesign annc Fonts & Typography 13 10-18-2005 08:42 AM


All times are GMT -8. The time now is 11:46 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Contents copyright 2004–2014 Desktop Publishing Forum and its members.